Results 1 to 2 of 2

Thread: iOS cocoa pod install 2.5.1 bug

  1. #1
    Neuer skobbler
    Join Date
    09.05.2016
    Posts
    1

    iOS cocoa pod install 2.5.1 bug

    Hi,

    I used to work with the SDK installed manually (on swift). The code I used works perfectly when I install the SDK manually. I tried to install it with cocoa pods. Everything works smoothly, all the functions are recognized and I don't get any error on the build.
    However, I can define the SKMapView but when I try to add the map to the view I get a NSException:

    Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SKVectorMapView displayTrafficWithMode:]: unrecognized selector sent to instance 0x7af23590'

    I haven't define any SKTrafficMode since I am using the public sdk. Any idea?

  2. #2
    Oberskobbler
    Join Date
    22.07.2014
    Posts
    399
    Please check if this was causing the issue:
    Go to your target-> Build Settings-> Other Linker flags and make sure there is a -ObjC flag.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •