Results 1 to 2 of 2

Thread: Emulator running problem

  1. #1
    Neuer skobbler
    Join Date
    02.03.2016
    Posts
    1

    Emulator running problem

    Hello everyone, I am new to skobbler map component there. I met some problem of running my test application on emulator. It get crushed on SKMapFragment showing with error "eglChooseConfig failed". Also I have tried to run example app from "DOWNLOADS" section on emulator and get crush every time too. I`ve used emulators api-23/api-21/api-19 with gpu "ON", GLES 2.0 is supported. In same time everything is working fine on actual devices.

    There stack trace:

    E/AndroidRuntime: FATAL EXCEPTION: GLThread 38 java.lang.IllegalArgumentException: eglChooseConfig failed
    at com.skobbler.ngx.map.SKMultisampleConfigChooser.ch ooseConfig(SourceFile:54)
    at android.opengl.GLSurfaceView$EglHelper.start(GLSur faceView.java:1024)
    at android.opengl.GLSurfaceView$GLThread.guardedRun(G LSurfaceView.java:1401)
    at android.opengl.GLSurfaceView$GLThread.run(GLSurfac eView.java:1240)
    03-02 11:22:21.809 1183-1183/? E/EGL_emulation: tid 1183: eglCreateSyncKHR(1294): error 0x3004 (EGL_BAD_ATTRIBUTE)
    Last edited by arty.dnepr; 02.03.2016 at 15:09.

  2. #2
    Oberskobbler
    Join Date
    22.07.2014
    Posts
    399
    Emulators don't react well when dealing with OpenGL rendering so we recommend testing on real devices – not even the settings we've provided in the guidelines don't always work reliably.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •