Results 1 to 2 of 2

Thread: iOS Swift: SKMapsSwiftDemo codesign error

  1. #1
    Neuer skobbler
    Join Date

    iOS Swift: SKMapsSwiftDemo codesign error

    Xcode build fails for the following error:
    ..../Frameworks/SKMaps.framework: invalid resource specification rule(s)
    Command /usr/bin/codesign failed with exit code 1
    I see that this error i related to: code object is not signed at all.
    I tried with Xcode 6.3 (and 6.4 beta), OS X 10.10.3, iOS 8.3 and with Xcode 6.1. OS X 10.9.5. iOS 8.1.3 receiving the same message.
    Before it worked now not. My app doesn't work but SKMapsSwiftDemo too.
    It works fine on every simulator.

  2. #2
    Join Date
    Please try to select the SKMaps.framework from the Frameworks folder and uncheck and then check back the SKMapsSwiftDemo target (in Target Membership).

    If this doesn't solves the issue you could check this question on Stackoverflow:”

    Apple is updating Swift constantly and these kind of bugs will most likely happen constantly.
    We are planning to release the next SDK in the next weeks and for the new version we will take care to include the latest updates, to avoid these kind of issues.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts