Results 1 to 2 of 2

Thread: [iOS 3.1.0] Linker error when Archiving build

  1. #1
    Neuer skobbler
    Join Date
    08.07.2016
    Location
    USA
    Posts
    9

    [iOS 3.1.0] Linker error when Archiving build

    I am trying to upgrade iOS from 3.0.2 to 3.1.0. I copied SKAdvisorResources.bundle and SKMaps.bundle from SKMapsResources folder, and SKMaps.framework from SKMapsSwiftDemo over the same named files in my last build which was Pods ScoutMaps-iOS-SDK 3.0.2. Everything works great when I'm testing, but when I go to Archive my build, I get the following linker error:

    ld: bitcode bundle could not be generated because '/Users/dembrey/ev-ios/Pods/ScoutMaps-iOS-SDK/SKMaps.framework/SKMaps' was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build file '/Users/dembrey/ev-ios/Pods/ScoutMaps-iOS-SDK/SKMaps.framework/SKMaps' for architecture armv7
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    Thanks in advance,
    Dusty

  2. #2
    Erfahrener skobbler
    Join Date
    12.09.2016
    Posts
    112
    Hi Dusty,

    In the meantime a new SDK version (3.2) was released. If interested, I can provide you with the latest builds. For that, please contact us at dev@telenav.com

    Best regards,
    Adrian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •