PDA

View Full Version : Issues updating from 2.5 to 3.0 beta



paulneesham
21.06.2016, 09:10
When a fresh install is done with the new Beta code the app starts fine and I cant find any issues.
But when the app has been updated from 2.5 to 3.0 on a device the maps do not display correctly

The app is using pre-bundled maps of GB.
On update I've tried removing the old maps using -> SKPackageManager.getInstance().deleteOfflinePackag e(), but this doesn't seem to make a difference.
(The only way to get the maps to display correctly is to uninstall then reinstall the app)


Is there anything else I should be doing when the app is updated?

Thanks
Paul Neesham

Adela_Silvia
21.06.2016, 14:44
We're investigating this. We'll get back asap with an answer.

paulneesham
07.07.2016, 10:39
Just wondering if you've confirmed this is a bug?

Adela_Silvia
08.07.2016, 10:50
The issue it's on our list- we'll let you know when we have an update

[Update 23-08-2016]: for prebundled packages you should overwrite the map resources package
Using deleteOfflinePackage won't delete the packages that are prebundled
Please follow the instructions for SDK update procedure
http://developer.skobbler.com/getting-started/android#sec040

paulneesham
12.09.2016, 15:55
Just thought I would update this thread with how I've fixed the problem.

When I detect that the app has updated from 2.5.1 to 3.0 I delete the directory used for SKMapsInitSettings
then let the app unpack the bundled maps like it would on a fresh install.

dandronic
13.09.2016, 09:14
Hi Paul,
We're glad to hear that you've solved the issue and thank you for sharing with us your solution.