PDA

View Full Version : No route - Route cannot be calculated



ptwat
07.09.2010, 20:56
I am new to this but, when I tried to use this app to go to an address, I get "No route - Route cannot be calculated". I tried it outside with unobstructed sky and still get this message. The address search finds the address okay also.

skobbler team
08.09.2010, 08:46
@ptwat - Sorry to hear that you're having a problem while using Skobbler.

Can you send me the exact start and destination address so we can reproduce this in our development and quality teams.


Thanks a lot,
Dana

ptwat
08.09.2010, 13:55
The start address is 5030 Sugarloaf Pkwy, 30044 (zip) Georgia and the destination is 10385 State Br Rd, 30022 Georgia.

skobbler team
09.09.2010, 09:07
Thank you for providing the requested information.

We investigated this issue and what we suggest is to try starting your navigation from a nearby road.
If you are already on a road then you can check the OSM data and see if your location is mapped here. Please report a map bug from the application if you encounter any obvious map problems.

Please let me know whether that solves your issue, and if you have any further questions please ask us anytime.

Thank you,
Adriana

ptwat
09.09.2010, 15:01
Thanks, I will try that.
However I got the "no route" response also while sitting at a McDonalds (1963 PLEASANT HILL RD, DULUTH, GA 30096-4625) with a destination of 5030 Sugarloaf Pkwy, 30044 also.

skobbler team
14.09.2010, 14:46
Hello ptwat,

It seams that your routing problems are caused by the combination of "5030 Sugarloaf Pkwy" and the "30044" zip code in the current state of the map data. If searching for this address, the returned one is: Sugarloaf Pkwy 5030, 30044, Lawrenceville, GA. If this returned address is used in navigation, it will fail with error message route cannot be calculated.
Interestingly, searching for "5029 Sugarloaf Pkwy" or "5031 Sugarloaf Pkwy" with 30044 zip code will return 5029(31) Sugarloaf Pkwy, 30097, Duluth, GA, and a navigation can be made to these addresses. If then one searches for "5030 Sugarloaf Pkwy, 30097" the returned address is "Sugarloaf Pwky 5030, 30097, Duluth, GA" and the navigation to this address is working.
If on the other hand, one searches for "Sugarloaf Pwky, 30044, GA" without house number, the returned address is "Sugarloaf Pkwy, 30044 Lawrenceville, GA" and the navigation works for this too.
I hope you can use one of the above solutions until the issue is resolved (which is probably missing map data). Remember that you can use the bug button while in navigation to report map problems, so that the OSM mappers know about the problems and be able to resolve them.
Sorry for the complicated response, I hope it can help you for now.

Thank you,
Daniel.

sweetypie
22.09.2010, 05:37
As an interested observer, I'd like to say, don't apologise for the complicated response. It's refreshing to see this display of technical curiosity matching that of the user. I hope that, as you become more established as a solution provider, you don't lose either that technical curiosity, or the desire to get beside users with their problems.

I'm finding that, as app developers become large, established companies, they lose the will to properly identify with the user experience.

Thanks again for your intelligence and curiosity, and I wish you well for the future.