View Full Version : GPS Nav 2 fails to launch iOS 5.1.1

08.05.2012, 03:58
Just upgraded iPad to iOS 5.1.1
Unfortunately GPS Nav 2 no longer runs. Skobbler screen comes up, then disappears.

16.05.2012, 17:33
Please restart your iPad.


16.05.2012, 18:20
Dear Christin:

Thanks, that solved the problem.

In addition, for some time I'm having trouble downloading US maps for offline use. I purchased the "world."
I tested with cellular data off, and the map did not pull in detail for a remote area in the US. However, it does seem to retain data for offline use, when in areas that I had previously explored with cellular data on.

Clicking Upgrades > Installation Status> lists as Purchased installable maps "Africa, Antarctica, Asia, Oceania, South America"
leads to a list of Installed Maps as "Europe, North America." At the bottom of North America, after a sequence of other islands, there's a final entry for "United States Virgin Islands," but I don't see any entry for mainland USA.

When I click Upgrades > Installable Maps it just comes up with a page suggesting that I purchase a country, continent or world. Clicking on Purchase a Country only reveals a list of European countries, all labeled as "installed." Clicking on Purchase a Continent reveals Europe, North America, Oceania, South America, all listed as "installed."

Suggestions on how to actually download US mainland coverage for offline use?

By the way, Europe worked fine for me in Vienna and the Wachau last month, although there were a few odd routing solutions that didn't make sense, easily overcome by staring at the map.

Best regards,

23.05.2012, 13:14
Hi Steve, please proceed as follows regarding the US States:

Delete and reinstall the app. Afterwards, please proceed as follows:

Start the app --> Upgrades --> Redownload --> enter here the password for the Apple ID (= email address) with which you bought the app and the maps the first time --> You have now access to your purchased products again, for free. Scroll down to the United States and install the States you currently require one by one to your device. It doesn't work at the moment to download the US States as a whole when you select the North American map package for installation. Sorry for the hassle!