PDA

View Full Version : Can't buy maps



Randyell
13.12.2011, 15:29
I have an iPad 2 and an iPhone 4S. I have the GPS app on both. I have tried dozens of times to purchase the world wide downloadable maps. After I go through the initial process, authorize the purchase, I get this error message:

"You Can't Purchase This

You must purchase the app that this item is for before you can purchase the item."

This makes no sense because I am attempting to make an in app purchase from the app which is be definition already purchased and on the devices. I have just loaded the most recent update on both devices, and still the same result.

I have rebooted, etc. nothing seems to change the result.

Does anybody have a solution?

Thank you.

Christin
14.12.2011, 11:24
Please read further info here: http://forum.skobbler.com/showthread.php?1586-What-can-I-do-if-the-In-App-Purchase-does-not-work.

Greetings,
Christin

Randyell
14.12.2011, 13:01
I read this thread. It is totally inapplicable to my problem. First of all I have all restrictions disabled on both devices. Second, I never set up a second account. Third, I had the same problem prior to downloading iOS5 on the Ipad 2 and I had it on the iPhone 3GS. If you are telling me I should delete and reload the program I will. When I go to the app in the App store, it shows that I have it installed.

So please make another suggestion. I would really like to buy the maps and rate this app 5 stars. I am unable to do so. Please help me.

Thanks.

Randyell
14.12.2011, 13:07
UPDATE: I deleted the program and reloaded it. Now I was able to purchase the maps.

Christin
14.12.2011, 16:33
Alright, perfect. Then I'll close this topic.

Best,
Christin